Issue

In Forecast > Upload, I've clicked to download a Forecast Data template, but it hasn't downloaded.

 

Cause

In our experience, the most likely causes of this issue are:

  • Your browser's settings are blocking the download
  • A browser extension is blocking the download
  • You may have clicked multiple times too quickly, disabling multiple downloads from your browser

 

Solutions

  1. Check your Browser Settings
  2. Check your Browser Extensions

 

Check your Browser Settings

First is to check your browser has blocked the download. If so, your screen may look like this

cloud_download_blocked_chrome_9.png

Click the download blocked icon and you'll be prompted for browser settings, which you can enable/disable on Castaway Cloud's website

cloud_download_blocked_chrome_6.png

Alternatively, you can head into your browser settings to enable/disable the setting overall

cloud_download_blocked_chrome_7.png

Or create a specific exception for Castaway Cloud

cloud_download_blocked_chrome_4.png

Once these settings are enabled, we'd recommend a quick refresh of Castaway Cloud, and then trying again. A successful download will show in the bottom left corner of your screen or can be seen in your browser download by typing Ctrl+J

cloud_download_blocked_chrome_8.png

 

Check your Browser Extensions

Once you have checked all of these settings, it's a good idea to check any extensions you may have enabled as some can block downloads from websites unless exceptions are provided. For this, as shown above in browser settings, make sure to allow the Castaway Cloud website through: 

 

https://cloudcastaway.com

 

If the troubleshooting steps taken still don't resolve the issue, please reach out to our Customer Success team at support@castawayforecasting.com